My First HDML BBS
[トップに戻る] [留意事項] [ワード検索] [過去ログ] [管理用]
お名前
Eメール
タイトル
メッセージ
メッセージ中には参照先URLと同じURLを書き込まないで下さい
参照先
暗証キー (英数字で8文字以内)
文字色

XHTMLなHPを正式公開しました。 投稿者:稲葉の城兎 投稿日:2007/11/25(Sun) 14:23 No.1783  
お陰様で何とかXHTMLなHPが出来たので、正式公開しました。尚、XHTML→HDML変換はやや問題が有ると貴サイトにも書かれてたので、当分はHDMLと並存させます。(一応XHTML単独でも、HDML実機にも対応可能な様に作ったつもりですが。)

良ければ、ご感想、ご意見など頂ければ有りがたいです。

http://hpcgi3.nifty.com/nihon-seitai/

http://homepage3.nifty.com/nihon-seitai/QR_all.gif
↑上記cgi用URLのQRコードです。

尚、下記の2点が実機でなと確認出来ない為、良ければ是非確認をお願いします。

(1)HDML実機で上記の振り分けcgiから、直接index.hdmlへのjump

   ・シミュレータだとUAと振り分け判定の関係で確認が出来ません。

(2)実機でのNAVITIMEへの地図リンクと戻りアドレスの確認

   ・認証の関係上、シミュレータではアクセスが拒否されます。


               ◇

今回の件では、貴サイト(My First HDML)のXHTMLの情報が役立って助かりました。

imodeやY!Keitaiだと、ちゃんとしたxhtmlの情報や仕様書がHPやpdfでキャリアから提供されてますが、EZwebの場合はキャリア提供の情報だけでは全然無理でした。

aタグのtitleの利用とかのEZweb独自仕様とかは、かなり利用させて頂きましたし、今回の絡みで、HDMLの方でも今更ですが <TAB>や<RIGHT>を初めて知って、便利に使えましたし。

ただ、貴サイトの情報はブラウザ6.0準拠の様で属性指定での記載方法がメインだったので、ブラウザ6.2とstyle指定での記載もあると、更に助かったと思います。

何はともあれお世話になりました。


Re: XHTMLなHPを正式公開しました... Kimura - 2007/11/26(Mon) 21:00 No.1784   HomePage

(1)index.hdmlへ直接ジャンプしました。

(2)NAVITIMEへの地図リンクはOKです。
(HDML機でも、結構地図がよく見えます)

「戻りアドレスの確認」とは、NAVITIME地図の下方に表示される[○○○○院]へきちんと戻るかどうか--ということでしょうか?
↑ということでしたら、きちんと戻りました。

#NAVITIMEは、HDML機にはHDMLを出力しているようですね。
今時めずらしいですね。


Re: XHTMLなHPを正式公開しました... 稲葉の城兎 - 2007/11/27(Tue) 10:48 No.1785  

実機での確認有難うございます。

index.hdml に直接飛んでホッとしました。一応UA偽装でも動作確認してはいましたが、シミュレータで確認出来ない場合、先般の件で実機での確認無しでは安心出来なかったので。(因みに、2箇所あるお気に入り登録のURLにもindex.hdmlを追記してますが、これは一応シミュレータで確認出来るので安心でしたし。)

「戻りアドレス」はそれの筈です。(多分^^;; 何しろ実物を見た事が無いので・・・。)

NAVITIMEは当初からau機に対応してた地図サイトなので、HDML機から始めた筈な為、そのお陰で綺麗に見えるのだと思います。

例えばMAPFANの携帯用地図リンクサービスである下記のiMAPFANは、文字通り当初はimodeでしか使えませんでしたし。

http://www.mapfan.com/mapfan/kmflink/index.html

あと現状でも、auの地図サービスである「ナビウオーク」や「助手席ナビ」等はNAVITIMEが提供してますし、au端末に最も対応してる地図サービスの筈です。

http://www.au.kddi.com/ezweb/service/navi.html

              ◇

当方のEZweb用HPの地図リンクは、最初はau北陸(だったかな?)が無料で提供してたモノで始めて、それがサービス停止になった時にNAVITIMEに代替させて貰いました。

その頃はNAVITIMEでユーザーリンクのサービスは、(確か)HP上で公開してませんでしたが、今回確認すると下記の様にちゃんとユーザーリンクを公開しており、非携帯でjumpすると以前は(確か)拒否されてた?のが今回はPC用にjumpします。

http://www.navitime.co.jp/?ctl=8300

ただPC用だと「戻りアドレス」が表示されない仕様ですし、営利のサイトがリンクする場合、認証が必要な事は同じでしたが。


Re: XHTMLなHPを正式公開しました... 稲葉の城兎 - 2007/12/07(Fri) 12:45 No.1789  

今週からYahoo!地図が詳細化されて、建物も表示される様になったので、サクッとXHTML版HPに採用してみました。

NAVITIME(及び今回Yahoo!地図と差し替えた「ちず丸」も)だと建物まで表示されないので、その補完が出来るので便利になると思ったからです。

但し、Yahoo!地図はHDML機のアクセスを拒否する為、HDML版HPの方は「ちず丸」を残してますが。(実機で確認した事が無いのですが、多分ちず丸ならHDML機でもHTMLで地図情報を提供してる?かなあ・・・・。^^;;)

              ◇

因みに、Yahoo!地図のリンク手段は、正式にはYahoo!から提供されてませんが、メールで問い合わせたところ、携帯で地図表示した時のURLを使ってリンクするのは構わない、と回答を頂いてます。

但し、いつURL形式を変えるか保証は出来ないので、そのつもりで、というお約束な断り書きも有りましたが。(^^;

尚、モバイル版Yahoo!地図は、UAで携帯以外を拒否判定してますが、IPアドレス迄は判定してないので、OW 6.2Kシミュでアクセスすればモバイル版がしっかり表示される為、確認が容易で助かってます。(NAVITIMEでは駄目ですが。)


P.S1
http://help.yahoo.co.jp/help/jp/mobile/mobile-02.html
|●サポート対象外の機種

|EZweb :A1000 C1000 C400 C3000 C5000シリーズ Tu-Ka
|     その他モノクロ端末

ありゃりゃ? C3000/C5000シリーズってWAP2.0端末だった筈。(もしかしてこれらはブラウザ6.0で、これ以降が6.2って話かな?)

うーーん、Yahoo!地図単独だとEZweb用HPに使うのは結構厳しい様ですね。うちはNAVITIMEの補完で使ってるから良いですが。


P.S2
http://hdml.jp/contents/sanalyze/sanalyzeReport.cgi

上記を見ると、確かにC3000/C5000シリーズはブラウザ6.0みたいですが、A1300/A3000/A5300シリーズもそうみたいですね。

ただ微妙に6.0.6や6.0.7/6.0.8の違いが有る様ですが。


Ezweb用ページで先に進まない 投稿者:たし 投稿日:2008/02/04(Mon) 20:15 No.1805  
お久しぶりです。
携帯をW56Tに機種変更したのですが、
こちらのEzweb用ページ(wap2.jpですよね?)にアクセスしても
自動で飛ばないどころかDashボタンも押せなくなって、まったく先に進めなくなっています。
細かいことですが、センタリングも効いてないようです。
解釈変わったのかなあ…
既知の問題であればすみません。

それと、56Tでも新絵文字は表示されるみたいです。


Re: Ezweb用ページで先に進まない Kimura - 2008/02/05(Tue) 00:11 No.1806   HomePage

たしさん、お久しぶりです。

W56Tのブラウザバージョンは、6.2_7.2.7.1.K.1.400
ですね。新しいバージョンのようです。

トップページ(http://wap2.jp/)を純WMLに変えてみました。
(今まではxhtml+WML)
また、<center>〜</center>を、<p align="center">〜</p>に変更しました。
これで先に進むことができるでしょうか?

新絵文字、見えましたか?
ありがとうございます。


Re: Ezweb用ページで先に進まない たし - 2008/02/05(Tue) 01:11 No.1807  

今度は、何も表示されなくなってしまいました。
画面真っ白の状態です(>_<)

後から気づいたのですが、絵文字対応BBSも書き込めなくなっています。
具体的には、フォーム入力後、投稿プレビュー画面で全角文字がすべて、半角のクエスチョン「?」等に文字化けしてしまうようです。
そのため、送信をしても「メッセージに全角文字がない のため投稿を中止しました」のエラーメッセージが出てしまい、投稿できなくなってしまいます。

KCP+の導入と共に、ezブラウザの仕様も結構いじったんですかね…


Re: Ezweb用ページで先に進まない Kimura - 2008/02/05(Tue) 10:21 No.1808   HomePage

> 画面真っ白の状態です(>_<)
あらら...(^^;

http://cgi.wap2.jp/
ではどうでしょうか?
Digestを使っていないバージョンです。

・SmallPICTが閲覧できるのであれば、WMLがまったく使えないということはなさそう。

・トップページ純WML化で真っ白になったということは、WMLの<onevent>要素が使えなくなっている可能性あり。
(XHTMLの時は使えていた??)

ちょっと調べてみる必要がありそうです。

そう言えば数年前、A5501Tでフォームに絵文字を入力可能なことを発見していただいたのも、たしさんでしたね。
あれ以来の衝撃かも。


Re: Ezweb用ページで先に進まない たし - 2008/02/05(Tue) 13:36 No.1809  

今度はOKのようです。

DASH、センタリングも効いていて、約2秒程で次のページに飛びます。
それと、背景色も付いています。

仕様変わるのは厄介ですよね…
まあそこが楽しかったりする事もありますが(^^;

絵文字の時は確かに驚きましたね!
僕は一応、当たりの機種を引いてるんでしょうかf^^


Re: Ezweb用ページで先に進まない たし - 2008/02/05(Tue) 21:41 No.1810  

絵文字も増えていますね。

568〜589番までのようです。


Re: Ezweb用ページで先に進まない Kimura - 2008/02/06(Wed) 00:31 No.1811   HomePage

> 絵文字も増えていますね。
> 568〜589番までのようです。
ギョエ〜ッ
やはり、ブラウザがかなりバージョンアップしている模様。。。

cgi.wap2.jp、テストしていただいてありがとうございます。
画面遷移したということは、<onevent>要素は大丈夫ですね。

wap2.jpのほうも再度修正しました。
ダイジェスト出力が良くなかったのかもしれません。

ちなみに、cgi.wap2.jpの構成は、
--------------------------
<html>
<head>
</head>
<wml:card>
</wml:card>
</html>
--------------------------

wap2.jpは、
--------------------------
<wml>
<head>
</head>
<card>
</card>
</wml>
--------------------------
となっています。

SmallPICTの投稿不具合は、原因がわかりません。


Re: Ezweb用ページで先に進まない たし - 2008/02/06(Wed) 15:56 No.1812  

wap2.jpの方もOKになりました。
以前使っていた機種と同じ挙動です。


もうひとつ気づいたのですが、「CGIデモ」内のメイクフォームでクリアキーを押すと
「リセット確認」の画面へ飛びますが、ここでもう一度クリアキーを押すとフリーズしてしまいます。
今のところ5回試して5回ともなっています。
この機能もwmlですよね…

この機種大丈夫かな(^^;


Re: Ezweb用ページで先に進まない Kimura - 2008/02/06(Wed) 20:53 No.1814   HomePage

フリーズですか。。。

> この機能もwmlですよね…
はい、そうです。
「リセット確認」の画面で、さらにクリアキーにフォームへ戻るタスク(throw:HDMLで言うところのCANCEL)を割り当ててみました。

※そもそもクリアキーに別のタスクを割り当てるのは、あまり良くないことかもしれません。

KCP+は、各ボタンへの機能割当が結構いろいろできる、という風に聞きかじっています。
それと関係あるのでしょうか?


Re: Ezweb用ページで先に進まない たし - 2008/02/14(Thu) 20:41 No.1816  

ちょっと返事が遅くなりました。

もうフリーズはしなくなりました。
クリアキーを押す度にフォーム画面とリセット確認をいったりきたり、という感じです。

各ボタンへの機能割当というのは…
Ezweb中を含め、その他の操作でもクリアキーやその他テンキー等に何か機能を割り当てるといったことはできないみたいですね。
特に関係は無いと思います。


Re: Ezweb用ページで先に進まない  - 2008/02/16(Sat) 09:13 No.1817   HomePage

機能を割り当てるのは、acceptキーとoptionsキーに限定した方がよさそうですね。

ところで、W56Tの使い心地はいかがですか?
au one ガジェット、利用していますか?


Re: Ezweb用ページで先に進まない たし - 2008/02/16(Sat) 18:06 No.1818  

Ezwebは割とキビキビ動くのですが、その他の場面での動作がかなり遅いですね。
特にau one ガジェット使用時が一番遅いので待ち受けからは外しています。
この機種の目玉機能ですが、こう遅いと使う気が起きないです…
そもそも、au one ガジェット自体の意味があまりわからないですしね(^_^;

Ezwebは本当に速いですよ。
新しいページを読み込む時の速度は今までとそんなに変わらないですが、
上下キーを押しっぱなしにしたときのフォーカスの移動が速く、
左右キーによるページスクロールも速いです。
ただたまに5〜10秒ほど固まってしまうことがありますが…


Re: Ezweb用ページで先に進まない Kimura - 2008/02/17(Sun) 23:39 No.1819   HomePage

> 特にau one ガジェット使用時が一番遅いので待ち受けからは外しています。
そうなんですか。。。
iGoogleを設定してみたものの、読み込みが遅くてブラウザのホームページからは外している..みたいな感じでしょうか (^^;

増えた絵文字、SmallPICTで投稿できない現象など、いじってみたいものです>KCP+


Re: 絵文字対応BBSで書き込めない... Kimura - 2008/04/28(Mon) 20:13 No.1823  

以下の原因がわかりました。

> 絵文字対応BBSも書き込めなくなっています。
> 具体的には、フォーム入力後、投稿プレビュー画面で全角文字がすべて、半角のクエスチョン「?」等に文字化けしてしまうようです。
> そのため、送信をしても「メッセージに全角文字がない のため投稿を中止しました」のエラーメッセージが出てしまい、投稿できなくなってしまいます。

KCP+端末では、WMLの仕様が変わったようです。
WMLフォームから送られた文字セットがUTF-8でないと、2バイト文字を受け付けないのです。
(当たり前ですが、HTMLでは起こりません)

絵文字対応BBSでは、au向けにWMLという言語で画面表示を行っており、WMLフォーム(=投稿フォーム)の文字コードは、Shift_JISなので、この問題に見事マッチ(?)してしまいます。

今時、WMLを使っているのが悪いのですが、なんだかVodafone3Gの時を思い出します。げんなり。

HTMLに書き直すか、このままWMLで突っ走るか考え中です。


smallpict掲示板のデバイスエラー 投稿者:りおん 投稿日:2012/07/05(Thu) 21:01 No.1925  
はじめまして。
smallpict掲示板をDL設置しました。

携帯からアクセスして、書き込もうとすると
デバイスエラーが出てしまいます。
対応作はありますでしょうか?

とても便利な掲示板で是非使いたいと思います。
よろしくお願いいたします。


Re: smallpict掲示板のデバイスエ... Kimura - 2012/07/05(Thu) 21:57 No.1926   HomePage

りおんさん、はじめまして。
SmallPICTのダウンロードありがとうございます。

デバイスエラーとのことですが、init.cgiの$dieHard2変数が1になっていたら0にしてみてください。

書き込もうとした携帯はdocomo・SoftBank・au・ウィルコム・イーモバイルのうちどのキャリアですか?
差し支えなければ機種名もお知らせ下さい。

また、画面には他にどのようなメッセージが表示されていますか?
SmallPICT側で「デバイスエラー」というメッセージは出していないはずなのですが。。。


Re: smallpict掲示板のデバイスエ... りおん - 2012/07/05(Thu) 22:18 No.1927  

とっても早いお返事に感激です。
ありがとうございます。

実は私はスマホなので、友人にメールで頼んで携帯からアクセスしてもらいました。

キャリアはAUで機種はSH009です。
「デバイスオープンエラー」だそうです。


Re: smallpict掲示板のデバイスエ... Kimura - 2012/07/05(Thu) 22:34 No.1928   HomePage

確認していただいてありがとうございます。

PCかスマホで、SmallPICT呼び出しの時に、smallpict.cgi?mode=check のようにしたら、赤文字で「NG」が表示される箇所がありますか?

smallpict.cgiのバージョンがわかりますか?
(smallpict.cgiファイルの5行目あたりに書いてあります)


Re: smallpict掲示板のデバイスエ... りおん - 2012/07/05(Thu) 23:00 No.1929  

「device.dat のパス: NG → device.dat」ありました!

全て同じディレクトリー内にあるので
$devFile = 'device.dat';にしてあるのですが、違うのでしょうか?


バージョンは2.7でした。


Re: smallpict掲示板のデバイスエ... Kimura - 2012/07/05(Thu) 23:31 No.1930   HomePage

> バージョンは2.7でした。
よかった。最新版ですね。

> $devFile = 'device.dat';
device.datがsmallpict.cgiやinit.cgiと同じディレクトリ内にあるのなら、設定は間違っていません。

device.datは、smallpict本体ファイルとは別にダウンロードしていただくことになっているのですが、設置されていない、ということはないでしょうか。
お手数ですが、今一度、device.datがサーバ上にあるかどうかご確認ください。

device.datは以下にあります。
http://wap2.jp/download/device.dat


Re: smallpict掲示板のデバイスエ... りおん - 2012/07/05(Thu) 23:37 No.1931  

確認しました。
device.dat.txtがサーバーにあります。
パーミッションは644です。


Re: smallpict掲示板のデバイスエ... Kimura - 2012/07/06(Fri) 00:00 No.1932   HomePage

> device.dat.txtがサーバーにあります。
このファイル名で設置されているのならば、init.cgiの設定は以下のようになります。
$devFile = 'device.dat.txt';

おそらくダウンロードした時に「.txt」拡張子が追加されてしまったのでしょう。


Re: smallpict掲示板のデバイスエ... りおん - 2012/07/07(Sat) 21:09 No.1933  

「.txt」拡張子が原因でした。
無事携帯から書き込むことができました。

とても、親切で迅速な対応ありがとうございました。
大切に使わせていただきます。


<br />について報告★ 投稿者:SAY★ 投稿日:2013/09/11(Wed) 13:47 No.1956   HomePage
今 smallpictのPC版をXHTMLへ改造してる途中なのですが…

コメントの所だけ<br />になりません…

あれ?って思い いろいろ検証したところ そちらのsmallpictもau版はコメントの所だけ<br />になってませんでした★

ご報告でした★(^^;


Re: <br />について報告★  - 2013/09/11(Wed) 18:34 No.1957   HomePage

SAY★さん、お久しぶりです。
ホームページ再開したのですね。とても斬新なデザインです。

> コメントの所だけ<br />になりません…
↑すみません。コメントと言うのは「引用部分」ということでしょうか?
もしよろしければ、こちらのSmallPICTデモ版に書き込んでいただけるとありがたいです。

SmallPICTの改造は大変でしょう?ひどいソースですから。

私も自分で書いたものなのに、
「誰だこんな書き方したのはっ」
「あたしだよ」
と、一人ツッコミしまくっています。


Re: <br />について報告★ SAY★ - 2013/09/11(Wed) 23:55 No.1958   HomePage

はい お久しぶりです★(^^)

コメントと書いたら分かりづらかったですね★(^_^;)

message_oya や message_ko の部分の所です★

後ほど書き込んでみますね★


ソースは…

たしかに分かり辛いです★w

…が 改行はしっかりされているので 改造面では苦になりませんよ★(^^)

僕の方では 最終作業でソースの配列を調整しようと思ってます★


Re: <br />について報告★  - 2013/09/12(Thu) 12:52 No.1959   HomePage

あ、了解しました。

投稿時に<br>にしちゃってますね。


Re: <br />について報告★ SAY★ - 2013/09/14(Sat) 12:19 No.1960   HomePage

自己解決しました★

メッセージの改行処理で

# メッセージの改行処理
$newMsg =~ s/\r\n/\n/g;
$newMsg =~ s/\r/\n/g;
$newMsg =~ s/\n/<br>/g;
while ($newMsg =~ /<br>$/i) { $newMsg =~ s/<br>$//gi; }



# メッセージの改行処理
$newMsg =~ s/\r\n/\n/g;
$newMsg =~ s/\r/\n/g;
$newMsg =~ s/\n/$br/g;
while ($newMsg =~ /$br$/i) { $newMsg =~ s/$br$//gi; }

に変えました★(^^;


絵文字の表示 投稿者:oka 投稿日:2013/02/16(Sat) 08:30 No.1943  
ひとつ質問があります。
絵文字をダウンロードして使わせてもらいたいと思っていますがサーバーにアップロードして絵文字選択からコードがコピーされても掲示板に絵文字が表示されません。
画像のプロパティを開いてみると利用不可となっています。
どうすれば利用可能にすることができるんでしょう?
パソコンに保存の時に画像を右クリック→名前を付けて保存で画像をいただきました。
これが間違っているんでしょうか?
ちなみに掲示板はe-padです。
初心者の為わからないので教えてください。
宜しくお願い致します。

| 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 |

NO: PASS:

- KENT & MakiMaki -
Modified by isso